読者です 読者をやめる 読者になる 読者になる

Re: 複数バージョンの Perl のモジュールインストール状況を調べるスクリプト

perl perlbrew

複数バージョンの Perl のモジュールインストール状況を調べるスクリプト | ミヤビッチの穴


が "perlbrew exec"使ったら One Linerで書けそうだったので
試してみた。

コード

  % perlbrew exec perl -wle 'do{eval "use $_;1";printf "%s=%s\n", $_, $@ ? "not installed" : ${$_ . '::VERSION'}} for @ARGV' モジュール..

結果

% perlbrew exec perl -wle 'do{eval "use $_;1";printf "%s=%s\n", $_, $@ ? "not installed" : ${$_ . '::VERSION'}} for @ARGV' CGI Encode Furl 
perl-5.10.1
==========
CGI=3.43
Encode=2.35
Furl=not installed


perl-5.14.1
==========
CGI=3.60
Encode=2.47
Furl=0.41


perl-5.8.9
==========
CGI=3.42
Encode=2.26
Furl=0.41